Installation firmwa...
 
Notifications
Retirer tout

Installation firmware espeasy sur weemos D1 Mini Lite

Page 1 / 2

fe36ca0d4d6bdcc500dbd432c3c08731?s=80&d=mm&r=g
Posts: 509
Admin
Début du sujet
(@christophe)
Membre
Inscription: Il y a 6 ans

Bonjour,

J’essaye d’uploader le firmware ESPEasy_R120 sur une Weemos D1 mini Lite mais sans succès.
J’ai téléchargé le fichier et j’ai suvi la procédure sur le tutoriel du site. Cela clignote bien jusque la fin mais je n’ai pas de réseau ESP_0 à la fin pour rentrer dans le paramétrage.

J’ai essayé en utilisant le sample blink sous ide arduino cela fonctionne correctement …

D’où cela pourrait il venir ?
Cordialement,
bypbop

Répondre
7 Réponses
fe36ca0d4d6bdcc500dbd432c3c08731?s=80&d=mm&r=g
Posts: 509
Admin
Début du sujet
(@christophe)
Membre
Inscription: Il y a 6 ans

as tu un message d’erreur particulier ?
as tu tenté de redémarrer ton weemos ?

Répondre
fe36ca0d4d6bdcc500dbd432c3c08731?s=80&d=mm&r=g
Posts: 509
Admin
Début du sujet
(@christophe)
Membre
Inscription: Il y a 6 ans

Merci palouf34, j’ai réussi à l’installer en fait on peut pas installer le R120 sur un wemos D1 Lite mais uniquement sur le wemos D1 et mini.
J’ai donc installé sur le wemos D1 !

Par contre j’ai un autre problème :

Voilà l’installation se passe bien et j’arrive à configurer Easy Esp. J’ai installé un module relai 5v sur la gpio 13.

j’arrive à declencher le relay via la commande http://192.168.1.87/control?cmd=GPIO,13,1 le relai s’enclenche correctement mais je n’arrive pas à l’éteindre en faisant http://192.168.1.87/control?cmd=GPIO,13,0

Quand je reboot la carte le relai passe à 0 et j’arrive de nouveau à l’enclencher

 

"log": "GPIO 13 Set to 0", 

"plugin": 1,

"pin": 13,

"mode": "output",

"state": 0


J’ai bien le state : 0

Je ne comprends pas pourquoi ! ??
Je viens de remarquer une chose que ce soit 0 ou 1 dans la commande, cela enclenche le relay quand il est à l’etat 0. Si je change de broche gpio 13 à 12 par exemple cela fait exactement la mm chose.
Cordialement,
bypbop

 

Répondre
fe36ca0d4d6bdcc500dbd432c3c08731?s=80&d=mm&r=g
Posts: 509
Admin
Début du sujet
(@christophe)
Membre
Inscription: Il y a 6 ans

tu n’as qu’un gpio de connecter sur ton relais ?
peut être qu’il faut l’inverser ?
tu as quoi comme module relais ?

Répondre
fe36ca0d4d6bdcc500dbd432c3c08731?s=80&d=mm&r=g
Posts: 509
Admin
Début du sujet
(@christophe)
Membre
Inscription: Il y a 6 ans

Bonjour
Un module relai classique pour arduino gnd à la gnd de ma wemos vcc au +5v et In au gpio 13 de mon arduino …

Bien à toi

Répondre
Page 1 / 2
Share:
Rejoignez nous!
Chercher sur le forum
Derniers tutoriels
Derniers messages postés sur le forum
Domotique et objets connectés à faire soi-même
Domotique et objets connectés à faire soi-même
Vous avez aimé ce tutoriel

Ne manquez plus les prochains projets

Recevez chaque semaine le récapitulatif des tutoriels et projets.

Vous pouvez vous désabonner à tout moment.